Jump to content


Photo

Air Video Server HD 2.2.3-beta7 released


  • Please log in to reply
29 replies to this topic

#1 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 02 May 2016 - 12:49 PM

Air Video Server HD  2.2.3-beta7 is available. 

 

Chances since 2.2.3-beta6

  • Fixed playback stalling with some files with embedded subtitles
  • Opus audio and VP9 experimental support (requires VLC)
  • Fixed A/V sync problems with flac audio

 

Changes since 2.2.3-beta5

  • Support for Android based GooleCast devices (Android TV). This required some rather significant changes to transcoding pipeline, so hopefully there won't be any regressions. Fingers crossed
  • Fixed server deadlock when scrubbing on Apple TV

 

Changes since 2.2.3-beta4

  • Fixed QuickSync related memory leaks

  • Fixed QuickSync decoding of corrupted TV recordings
  • ​Reduced video artifacts when playing corrupted TV recordings
  • Fixed A/V sync issue with interlaced (60fps) corrupted TV recordings. 

Changes since 2.2.3-beta3

  • Found and fixed some more memory leaks
  • Fixed playback of MPEG files with bogus packets at the end
  • Fixed regression where seeking would hang sometimes
  • Fixed playback of some LOAS AAC streams
  • Fixed playback for MP4 files with invalid color table id value
  • Updated Sparkle on OS X (Server now requires OS X 10.7+)

Changes since 2.2.3-beta2

Changes since 2.2.2

  • New caching implementation should significantly improve performance with high latency network drives
  • Important QuickSync fixes
    • Fixed encoding for 60fps files

    • Fixed the No frames found before end of file bug on some files. Note that if you have encountered this you may have to rebuild thumbnail cache after installing the beta

    • More reliable recovery on device failure

  • Fixed missing audio during ChromeCast playback on Nexus and other android based devices

  • Fixed PCM audio playback for some matroska files

  • Better compatibility with Apple TV 4

  • Hardware accelearated transcoding on 12" MacBook

  • General playback improvements

Download for Mac OS X (universal)

 
More information about hardware acceleration can be found here.


#2 tdoane78

tdoane78

    Advanced Member

  • Members
  • PipPipPip
  • 140 posts

Posted 04 May 2016 - 02:48 AM

Metadata!!!!!!!



#3 mabu

mabu

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 04 May 2016 - 05:34 PM

Hello! I do have some .avi-files which don't work anymore since server 2.2.3-beta6. They are playing maybe for one second and then it skips to the next video (autoplay next video is on).

Same problem with beta7. After going back to beta5 they work again.

The files are encoded with DIVX 5 (DivX 5.1.1) 29,970 fps,1251 kbps, audio: MPEG2-Layer 3 240000Hz, 32kb/s mono

 

Windows 10 64 bit, iPadAir2 newest client, VLC 2.2.2 64bit



#4 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 05 May 2016 - 12:23 PM

mabu, can you maybe upload one of the files here?

 

https://www.mediafir...54ce133b8c0cb0b

 

It could be a regression, there have been big changes sinces beta5 in order to accomodate android tv devices



#5 mabu

mabu

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 05 May 2016 - 01:25 PM

Thank You for trying to help!

 

Unfortunately I can't upload any of these videos, because of their private nature...

 

I tested a litte more and it seems that the problem only occurs if the DIVX-video has mono sound (very old videos). The ones working do all have stereo sound.

I will try to find a video which I can upload...



#6 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 06 May 2016 - 12:07 PM

mabu, thanks for the file. Should be fixed in next beta.



#7 mabu

mabu

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 06 May 2016 - 01:20 PM

hmmm, I didn't upload anything until now. Seems that someone else had the same problem and uploaded a file...

Looking forward to the next update

 

Thanks



#8 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 06 May 2016 - 02:14 PM

That's possible. I received avi file with mono audio exhibiting the symptoms that you've described so I assumed that you've uploaded it.



#9 pacman02

pacman02

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationSydney

Posted 19 May 2016 - 11:33 AM

Be good to password protect AirVideo Server so users cannot reset password or change settings if they have access to the device



#10 tdoane78

tdoane78

    Advanced Member

  • Members
  • PipPipPip
  • 140 posts

Posted 19 May 2016 - 04:02 PM

Be good to password protect AirVideo Server so users cannot reset password or change settings if they have access to the device

Access to the device (ipad, iphone) or the server? Unaware of the first even being possible (how does that work)? Second the O/S security should cover that.



#11 pacman02

pacman02

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationSydney

Posted 22 May 2016 - 03:44 AM

I was talking on the server side. No security for the user to not make changes.



#12 pacman02

pacman02

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationSydney

Posted 22 May 2016 - 03:45 AM

I have found with the 2 last releases that the video often pauses and need to exit Airvideo on iOS and start again and it works. No specific time this happens or what video type.

Prev versions never had this issue.



#13 abat119

abat119

    Member

  • Members
  • PipPip
  • 25 posts

Posted 29 May 2016 - 07:11 AM

I have found with the 2 last releases that the video often pauses and need to exit Airvideo on iOS and start again and it works. No specific time this happens or what video type.
Prev versions never had this issue.


Same here. I thought it was an internal network issue (kept restarting my router) until I reverted back to the latest stable release 2.2.2.

Didn't think of posting the issue since I thought it was just on my end...

#14 ussjtrunks

ussjtrunks

    Member

  • Members
  • PipPip
  • 18 posts

Posted 29 May 2016 - 03:46 PM

after watching multiple videos over the last few weeks I'm happy to confirm that the subtitles stalling and flac audio sync are fixed :) great work as always



#15 IceIceBird

IceIceBird

    Member

  • Members
  • PipPip
  • 26 posts

Posted 09 June 2016 - 12:18 PM

Google Cast to Philips Smart TV (Android 5.1) seems to not work with some x264 720/1080 ac3 files anymore. Has there been any changes to this lately?



#16 cosmoxl

cosmoxl

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts

Posted 10 June 2016 - 12:39 PM

how long is this going to sit in beta?  a lot of people aren't "power users" and don't check forums for beta versions.  this need to be released and pushed for automatic update ASAP.  It's been too long.



#17 tdoane78

tdoane78

    Advanced Member

  • Members
  • PipPipPip
  • 140 posts

Posted 11 June 2016 - 12:38 AM

how long is this going to sit in beta?  a lot of people aren't "power users" and don't check forums for beta versions.  this need to be released and pushed for automatic update ASAP.  It's been too long.

 

Seems a bit arbitrary - why is there a need for an ASAP automatic update to the newest version of the server software? If the end user isn't having issues they are fine with the stable release.



#18 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 11 June 2016 - 02:56 PM

Google Cast to Philips Smart TV (Android 5.1) seems to not work with some x264 720/1080 ac3 files anymore. Has there been any changes to this lately?

 

Not really. Do you get any error message?



#19 IceIceBird

IceIceBird

    Member

  • Members
  • PipPip
  • 26 posts

Posted 16 June 2016 - 07:54 AM

Not really. Do you get any error message?

Cleared the data and cashed folder for the Google Cast app on the TV and now it workes.



#20 IceIceBird

IceIceBird

    Member

  • Members
  • PipPip
  • 26 posts

Posted 17 June 2016 - 11:24 PM

Any chances that the .srt file tags {\an1}, {\an2}, {\an3} etc etc going to make it into this or is that on the app front?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users