Jump to content


Photo

Air Video Server HD 2.2.3-beta5 released


  • Please log in to reply
29 replies to this topic

#1 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 17 February 2016 - 08:52 PM

Air Video Server HD  2.2.3-beta5 is available. 

 

Changes since 2.2.3-beta4

  • Fixed QuickSync related memory leaks

  • Fixed QuickSync decoding of corrupted TV recordings
  • Reduced video artifacts when playing corrupted TV recordings
  • Fixed A/V sync issue with interlaced (60fps) corrupted TV recordings. 

Changes since 2.2.3-beta3

  • Found and fixed some more memory leaks
  • Fixed playback of MPEG files with bogus packets at the end
  • Fixed regression where seeking would hang sometimes
  • Fixed playback of some LOAS AAC streams
  • Fixed playback for MP4 files with invalid color table id value
  • Updated Sparkle on OS X (Server now requires OS X 10.7+)

Changes since 2.2.3-beta2

Changes since 2.2.2

  • New caching implementation should significantly improve performance with high latency network drives
  • Important QuickSync fixes
    • Fixed encoding for 60fps files

    • Fixed the No frames found before end of file bug on some files. Note that if you have encountered this you may have to rebuild thumbnail cache after installing the beta

    • More reliable recovery on device failure

  • Fixed missing audio during ChromeCast playback on Nexus and other android based devices

  • Fixed PCM audio playback for some matroska files

  • Better compatibility with Apple TV 4

  • Hardware accelearated transcoding on 12" MacBook

  • General playback improvements

Download for Mac OS X (universal)

 
More information about hardware acceleration can be found here.


#2 tdoane78

tdoane78

    Advanced Member

  • Members
  • PipPipPip
  • 140 posts

Posted 17 February 2016 - 11:13 PM

Everytime I check for metadata - killing me ;-)

 

-Tim



#3 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 17 February 2016 - 11:22 PM

Yeah, sorry Tim, server update will not be enough for something like that. Especially not .x maintenance updates :)


  • perfecblue and tdoane78 like this

#4 cosmoxl

cosmoxl

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts

Posted 18 February 2016 - 01:29 PM

Thanks for all the work you're doing to get the server resilient.  I actually deleted my recordings from last week, which had the errors.  So, I can't really test beta5.  Sorry, I didn't think I'd need them anymore. :(

 

edit: wow!  got the file back from you and tested it.  no problems!  it just moves right through the errors and keeps sync with no memory leak.  great work!



#5 Chio

Chio

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 19 February 2016 - 05:31 AM

I'm with Tim on metadata. I'm hoping that can be a future feature.

#6 kings1204

kings1204

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 19 February 2016 - 12:50 PM

After using beta 5 a few days :

 

x32 version works perfect. When finished transcoding airvideoui remains using only 10 - 15 Mb of RAM

 

x64 version works perfect : When finished transcoding airvideoui remains using 120 - 140 Mb of RAM



#7 22hand

22hand

    Member

  • Members
  • PipPip
  • 11 posts

Posted 19 February 2016 - 03:08 PM

can't even start in mac OS X



#8 IceIceBird

IceIceBird

    Member

  • Members
  • PipPip
  • 26 posts

Posted 19 February 2016 - 03:20 PM

I really would have liked to se an GUI option/setting so that we can disable the bonjour warning (nag screen).



#9 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 19 February 2016 - 05:10 PM

22hand, which OS X version are you using?



#10 kings1204

kings1204

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 19 February 2016 - 11:25 PM

Air video x64 still have memory leak, slower but it has it.

 

After another day working it is consuming 345 MB RAM (AirvideoserverUI) (nobody connected) and increasing

 

x32 version working perfect.



#11 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 19 February 2016 - 11:47 PM

Please send the logs from server (Create Archive from Logs) to support(at)inmethod.com 

 

This certainly looks like a leak, but I don't see any reason why 64bit version would behave any differently than 32bit.



#12 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 20 February 2016 - 12:05 AM

In any case, this is not a small leak. I'll see if I can add tracing functionality, that would log leaked buffers with corresponding file name; This should make reproducing the leaks much easier.



#13 kings1204

kings1204

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 20 February 2016 - 12:34 AM

support(at)inmethod.com is an emai ? (changing (at) for @) ??

 

Hope so cause it´s sent  :rolleyes: 



#14 22hand

22hand

    Member

  • Members
  • PipPip
  • 11 posts

Posted 20 February 2016 - 02:41 PM

I need to reboot the iMac so it can re-start..also after apple Tv gen 4 failed access, all my iDevices can't access the server until I reboot the iMac..

I am using latest version of Mac OS X 



#15 22hand

22hand

    Member

  • Members
  • PipPip
  • 11 posts

Posted 20 February 2016 - 02:42 PM

and when I try to quite the server, the beachball comes out!



#16 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 20 February 2016 - 08:55 PM

22hand, beachball on server quit can happen sometimes, but it shouldn't take longer than 10 seconds. Regarding the restarts, that really seems that something is quite wrong with your setup. No matter what the server does, it shouldn't require computer restart.



#17 ussjtrunks

ussjtrunks

    Member

  • Members
  • PipPip
  • 18 posts

Posted 22 February 2016 - 12:15 PM

I have one set of anime episodes that play fine locally but have a audio delay when watching on my ipad, its strange as its the only set that does this :(



#18 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 22 February 2016 - 10:58 PM

ussjtrunks, can you upload sample file here? I'll take a look

 

https://www.mediafir...54ce133b8c0cb0b



#19 Beta

Beta

    Member

  • Members
  • PipPip
  • 11 posts

Posted 25 February 2016 - 08:38 PM

It look promising this version!!! Ill test it this weekend. No more artifacts men that took awhile.
If everything will be fine this weekend please please do not break this version. The latest version 2.1.0 beta 3 was also good.
After that down the hill. Every version after that was crappy. now ill test it know why wait.

#20 Beta

Beta

    Member

  • Members
  • PipPip
  • 11 posts

Posted 25 February 2016 - 08:58 PM

It look promising this version!!! Ill test it this weekend. No more artifacts men that took awhile.
If everything will be fine this weekend please please do not break this version. The latest version 2.1.0 beta 3 was also good.
After that down the hill. Every version after that was crappy. now ill test it know why wait.

Tried and no go. 2.1.0 beta 3 is still working correctly and this new beta fails :( i guess no luck.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users