Jump to content


Photo

Air Video Server HD 2.2.3-beta3 released


  • Please log in to reply
28 replies to this topic

#21 cosmoxl

cosmoxl

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts

Posted 11 February 2016 - 01:45 AM

cosmoxi, it is unlikely that this is a change between betas. It's more likely that the memory leak just happend "right now". If you notice any action that dramatically increases memory usage and it return back after playback, please let me know. I'm pretty sure there is a memory leak, the problem is, noone knows when exactly does it happen. (it could be specific file, specific decoder configuration - i.e. some direct show filters, if not using VLC, specific order of actions (i.e. multiple transcoding sessions), etc.)

 

VLC is installed and I'm using hardware decoding and encoding.  Playback was on recorded TV, mpeg2.  The mpeg2 files had random problems due to low quality signal so perhaps something is buggy and freaks out with errors in source files.  Still testing

 

edit: removed VLC just for testing and played back an mpeg2 recorded under poor signal to try to recreate the problem.  it came to a point in the video where playback just stopped because something in the workflow couldn't handle the exception in the source.  I looked on my desktop and could see the memory usage rising.  Problem is once I ask ATV4 app to exit out of the video the memory isn't released even though the server CPU and GPU tasking stops. 



#22 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 11 February 2016 - 02:53 AM

If possible, can you please upload sample file that causes the leak here?

 

https://www.mediafir...54ce133b8c0cb0b



#23 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 12 February 2016 - 12:06 AM

beta 4 is out, fixes couple more memory leaks 

 

http://forums.inmeth...beta4-released/



#24 cosmoxl

cosmoxl

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts

Posted 12 February 2016 - 04:13 AM

If possible, can you please upload sample file that causes the leak here?

 

https://www.mediafir...54ce133b8c0cb0b

 

I'll test beta4 first.  If I still have a problem I'll work to find a cut that contains a problem spot.



#25 cosmoxl

cosmoxl

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts

Posted 15 February 2016 - 08:13 PM

I've cut a small sample that contains errors or something that is causing the server to hiccup with corresponding huge rise in swap and RAM usage.  One thing to note - the increase in swap and RAM usage seems to correlate with the size of the file.  The small sample led to a much smaller increase in memory usage as compared to a crash during playback of the original source.  Small sample is uploaded to the link above. 



#26 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 16 February 2016 - 12:23 AM

Thanks. I'll look into it. Any memory consumption that doesn't go away after transcoding session is finished is significant, no matter how small.



#27 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 16 February 2016 - 12:48 AM

cosmoxi, can you please send me logs from Air Video Server HD (Create Archive from Logs) to support(at)inmethod.com? The sample file doesn't seem to leak anything when I tested it, so I'd like to know which decoders are involved in your case. This could be decoder specific leak.



#28 cosmoxl

cosmoxl

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts

Posted 16 February 2016 - 02:02 PM

cosmoxi, can you please send me logs from Air Video Server HD (Create Archive from Logs) to support(at)inmethod.com? The sample file doesn't seem to leak anything when I tested it, so I'd like to know which decoders are involved in your case. This could be decoder specific leak.

 

done.  I don't think I specified but hopefully you'd see in the logs that I reinstalled VLC as I tested since that seems to be the baseline codec source.  I was still having problems with and without VLC.



#29 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 16 February 2016 - 07:50 PM

cosmoxi, I've updated windows builds to beta4u1, which should fix the quicksync memory leak (and also fix stuck playback on the file you've sent me)

 

http://forums.inmeth...beta4-released/






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users