Jump to content


Photo

Apple TV Server Connection Issues


  • Please log in to reply
11 replies to this topic

#1 newdeepdan

newdeepdan

    Member

  • Members
  • PipPip
  • 19 posts
  • LocationNew York

Posted 08 January 2016 - 02:44 PM

I haven't had any issues with the Apple TV and iOS apps for a week, but lately its been having issues showing the availability of the computer I use to store the files. For example if I'm browsing the contents on the Apple TV, then go back to the main menu of the Apple TV app, it shows my computer no longer being available when I was just using it. I'll have to exit and enter the app a few times before it will show up as being available again. I think the issue is something with the server app not broadcasting quickly/frequently that it is there.

 

Some network info:

 

Apple TV: Ethernet connected

Server Machine: Ethernet connected, OSX 10.11.2, Air Video Server HD 2.2.2

 

Both machines have DHCP reservations so they have a static IP address.


Love Honor Truth


#2 fb12

fb12

    Member

  • Members
  • PipPip
  • 27 posts

Posted 08 January 2016 - 04:46 PM

I have been experiencing the same thing these last few days. I had to restart the server software to get things going again.

 

I thought my Mac was getting old ;-( but according to my Apple TV the app was updated on 4th Jan. Sounds like it could be a bug???



#3 Guest_Nicolas_*

Guest_Nicolas_*
  • Guests

Posted 12 January 2016 - 04:17 AM

Same here: things used to work very well, now I'm rarely able to connect to the server at all and even when I do, I frequently get disconnected.



#4 RXDI

RXDI

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts
  • LocationTampa

Posted 12 January 2016 - 09:21 PM

I had to go back to Server Version 2.2.1 I had too many issues with 2.2.2.

 

Try doing that guys and see if it fixes the issue for you.



#5 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 14 January 2016 - 02:37 PM

RXDI, what kind of issues? There hasn't been many changes in 2.2.2, what exactly broke for you?

 

newdeepdan, can you please check if the server is running when you get disconnected? There are two things that can be causing this - either the server crashes, or TCP connection from client to server is terminated and the client is unable to reconnect. The second would mean that there are networking issues of some kind.



#6 RXDI

RXDI

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts
  • LocationTampa

Posted 15 January 2016 - 03:34 PM

RXDI, what kind of issues? There hasn't been many changes in 2.2.2, what exactly broke for you?

 

I started having server crashing issues like I did before 2.0. If you remember, I have over 30 people connecting to my server and it used to crash every couple days and not restart itself.

I had been running fine up until I went to 2.2.2 and then it started doing it again. I'm back to 2.2.1 and running smooth again now.

 

It's hard to test it because everyone gets knocked off and I get a flood of posts about it. For now I am sticking to 2.2.1



#7 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 15 January 2016 - 09:12 PM

RXDI, can you send me the logs to support(at)inmethod.com? (at least other.log)  I'll see if I can find appropriate crash reports. I just went through all commits between 2.2.1 and 2.2.2 and didn't see anything that could be possibly causing crashes.



#8 RXDI

RXDI

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts
  • LocationTampa

Posted 18 January 2016 - 08:14 PM

RXDI, can you send me the logs to support(at)inmethod.com? (at least other.log)  I'll see if I can find appropriate crash reports. I just went through all commits between 2.2.1 and 2.2.2 and didn't see anything that could be possibly causing crashes.

 

 

Sent.



#9 Guest_drm0223_*

Guest_drm0223_*
  • Guests

Posted 25 January 2016 - 08:06 PM

We are recently experiencing a problem with the Apple TV app losing an existing connection, mid-play.  (No problem with the iPhone app accessing the same server).  The error in other.log is

 

16:16:51 ERROR 00 airconnect.session AirConnect.cpp:660 - - - - - - Did not received heartbeat from client in 30 seconds, considering the connection dead.

 

The video just stops playing on the Apple TV.  The server is still up as I can access it from an iPhone.

 

The solution is to restart the Apple TV, while making no change whatsoever to the server.  Once restarted the Apple TV connects to the same video and starts up about 10 secs earlier in the video.

 

I was using OS X 10.11.2 for the server machine.  Just upgraded to 10.11.3.  I'll see if the problem goes away.

 

Other than this annoyance, it's a great product!  Never had a problem with the iPhone access and have used it and the earlier non-HD version for years.

 

Thanks for any help!



#10 Guest_Tim_*

Guest_Tim_*
  • Guests

Posted 29 January 2016 - 10:13 PM

Same here with Apple tv 4 and server 2.2.1.

Playing and when after a few mintues -> CRash

 

What I did before: When I updated tv-os the problems begun! But I cannot go back .:-(



#11 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 30 January 2016 - 03:20 PM

Can you try latest server beta and let me know if the issues still persist?

 

http://forums.inmeth...beta2-released/



#12 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 31 January 2016 - 10:36 PM

Beta-Version helps but playback is frezing from time to time. A lot better than before but unuseable.

Connection wifi ac > 80%; server xeon: win 7 sp1 64 bit 4gb connected by 1gb to synology 1813+... The network is pro.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users