Jump to content


Photo

Port forwarding question

Port forwarding Port Mapping

  • Please log in to reply
5 replies to this topic

#1 fb12

fb12

    Member

  • Members
  • PipPip
  • 27 posts

Posted 24 December 2015 - 09:52 PM

Hi,

I have to periodically restart my Air Video HD servers because of UPnP port mapping issues. So I'd like to setup Port Forwarding. Which ports can I use? As I have 2 media servers on the same network.

Thanks in advance.
  • chrystalpq69 likes this

#2 RXDI

RXDI

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts
  • LocationTampa

Posted 27 December 2015 - 03:09 AM

You can create/choose any port you want. I stick to a 6 number convention.

 

Uncheck "Enable Auto Port Mapping", then add your port number under "Listen on Custom Port".

 

I would reboot the machine too.



#3 fb12

fb12

    Member

  • Members
  • PipPip
  • 27 posts

Posted 27 December 2015 - 11:33 AM

Thank you for the info. Worked a treat.

Thanks again.

#4 greynolds

greynolds

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 13 July 2016 - 10:11 PM

I'm having trouble getting the "Listen on custom port" feature to work.

 

As of today, we have 2 PC's in the house running Air Video server.

 

The first server is using the standard port (45633) and works just fine, including the "Test Connection" button.  For access from outside the house, we have the NAT settings in our router configured to direct external port 45633 to port 45633 on the first server.

 

The 2nd server obviously needs to use a different port on the external network connection so that NAT will find the correct PC.  So I initially unchecked "Enable Auto Port Mapping", checked "Listen on custom port", and entered 45634 as the port number.  For access from outside the house, I configured the NAT settings on the router to direct external port 45634 to port 45634 on the 2nd server.  When I configure the iOS Air Video HD app to connect to the PC on port 45634, it doesn't connect and gives a timeout error.  Additionally, the "Test Connection" button on the server fails with a message that it's unable to connect.  After finding this thread, I also tried rebooting the server, but that didn't help.  I should also note that I seem to be having problems getting the value I enter for the custom port to stick (at least one time, I found it was blank after rebooting).

 

So I switched the second server back to the default port (I checked "Enable Auto Port Mapping" and unchecked "Listen on custom port").  I then changed the NAT settings on the router to direct external port 45634 to port 45633 on the 2nd server.  After doing this, the iOS app can now connect to the PC.  However, the "Test Connection" button on the server still fails (presumably because it's trying to connect to port 45633 instead of 45634).

 

Given that I can get it to work, I suppose I should be happy enough, but it feels like there's a bug here.  It's also possible I'm doing something stupid...  Is there anything else I can do to get this to work more smoothly?

 

Aside from this issue, this seems like a great solution for watching videos from home on my iPad when I travel.



#5 fb12

fb12

    Member

  • Members
  • PipPip
  • 27 posts

Posted 14 July 2016 - 06:39 PM

Hi,

 

Excuse my ignorance, I'm still a bit of a novice. I found setting up static IP addresses worked for me. 



#6 greynolds

greynolds

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 14 July 2016 - 09:46 PM

Hi,

 

Excuse my ignorance, I'm still a bit of a novice. I found setting up static IP addresses worked for me. 

The PC's have reserved DHCP addresses (similar to static IP's, but moves the configuration to the router which is often preferred as it allows you to manage all the IP addresses in one place and ensure there aren't any conflicts); it's definitely not an IP address issue.  The issue is a port mapping issue of some sort.  The Air Video server program doesn't seem to be honoring the settings I made to change away from the default port.

 

We've got several other similar services configured across several PC's, all of which work just fine.  In fact, we've got a similar situation with one of them where we have the same service running on 2 different PC's, so we configured one with the default port and the other with an alternative port so they won't conflict and it works just fine.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users