Jump to content


Photo

Air Video Server HD 2.2.1


  • Please log in to reply
55 replies to this topic

#1 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 30 October 2015 - 04:20 PM

Air Video Server HD  2.2.1 is available. 

 

Changes since 2.1.4

  • Supports Air Video for Apple TV
  • Merged folders - you can now enter same name for multiple shared folders and they will be displayed as one
  • Hardware accelerated transcoding enabled by default, if supported
  • Other bugfixes
  • Fix for Server ID problem when connecting remotely (2.2.1)

Download for Mac OS X (universal)

 
More information about hardware acceleration can be found here.
 
EDIT: Updated OSX release to u1, which fixes automated updates.

  • janiedjs likes this

#2 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 30 October 2015 - 08:35 PM

Well, I really hoped this would go smooth, but as per usual, we did mess something up. 

 

1) Air Video Server HD 2.2.0 and 2.2.1 for OS X will not be able to auto-update. This is fixed in 2.2.1u1, but if you already updated to 2.2.0 or 2.2.1 you'll have to update to 2.2.1u1 manually.

 

2) Resolving through Server PIN will not work for some users. Unfortunately this one needs to be fixed in client update. The update has already been submitted to Apple and I asked for expedited review, but there's no way of knowing if it will be granted. If this affects you, it is possible to downgrade the server to 2.1.4 ( OSX, Win32, Win64 ) until the update gets approved.



#3 IceIceBird

IceIceBird

    Member

  • Members
  • PipPip
  • 26 posts

Posted 31 October 2015 - 09:23 AM

Now when we have merged folders we really need a jump to(start letter of folder)/search option of some kind in the client. Because now when you "merge" your folder from different drives it takes for ever to scroll trough.



#4 jonmacguru

jonmacguru

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 31 October 2015 - 04:35 PM

We use AirServer HD on iOS, but have been using Plex Connect to our Apple TVs (gen 3)..  I have a new ATV gen 4 at home now and I'm hoping that your mention of support for Air Video HD on Apple TV means that you have a native App coming to the new TVos app store.  Is that what you are referring to in this post?  Thanks,



#5 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 31 October 2015 - 05:08 PM

It's  already there, try search for Air Video in the AppStore :)



#6 Shiva

Shiva

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 31 October 2015 - 06:36 PM

I've juste updated on OS X and during the update a password prompt saying "Need a password to update" (or something like this) show up.

 

It was not the standard OS asking for admin rights. And I see that you don't even know why a password prompt show up during install (http://forums.inmeth...word-to-update/).

 

Is this a scam to get users password?



#7 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 31 October 2015 - 07:13 PM

It's most definitely not a scam to get users passwords. It seems that sparkle, framework responsible for autoupdates, does this sometimes, but it's very hard to reproduce so I can't tell for sure. Could it be that your user account doesn't have permissions to write to /Applications folder?



#8 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 31 October 2015 - 07:15 PM

Actually, according to this thread, the password prompt is displayed when sparkle fails to mount the image for some reason and then thinks the image is password protected (which it isn't).



#9 Beta

Beta

    Member

  • Members
  • PipPip
  • 11 posts

Posted 31 October 2015 - 10:46 PM

Back to version 2.1.0 beta 3 !!!!! Don't know why the other versions have so many problems....
Sound and picture rocks on version 2.1.0 beta 3! If you have problems try it out! It's the most stable so far!

#10 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 01 November 2015 - 02:21 AM

Beta you really need to be more specific. What exactly is wrong with 2.2.x regarding sound and video?



#11 evilpants

evilpants

    Member

  • Members
  • PipPip
  • 10 posts

Posted 01 November 2015 - 09:49 AM

I just registered cos I wanted to say, I had the password prompt too - but I simply clicked 'submit' without putting a password in, and it carried on with the install problem-free.

 

I'm currently installing the Apple TV app, and I'm so excited about it :-)

 

Edit: at first run it wouldn't play my videos. An mkv video served successfully served to my iPhone returns this error: coremediaerrordomain error -12646 - stream type unrecognized

 

But now everything seems to be ok. I am *unbelievably* thrilled about this app, guys - I had no idea you were making it, and was gonna look for Plex or something like that. *Thank you*


Edited by evilpants, 01 November 2015 - 09:54 AM.


#12 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 01 November 2015 - 10:25 AM

That's a weird error really. If you get it again, please send logs from Air Video Server HD (Create Archive from Logs) to support(at)inmethod.com . Thanks



#13 evilpants

evilpants

    Member

  • Members
  • PipPip
  • 10 posts

Posted 01 November 2015 - 10:53 AM

That's a weird error really. If you get it again, please send logs from Air Video Server HD (Create Archive from Logs) to support(at)inmethod.com . Thanks

 

No problem, I'll do it if it happens again. Everything seems fine now. I wonder if it was starting to play before it was ready - y'know how the iOS client has "loading details" when you go into a new folder? Well, when I went into the folder I wanted to play from, there were no thumbnails generated yet; iOS clients won't let you play til it's downloaded the stuff it needs, but the Apple TV client started playing immediately - I wonder if it's related to that. Essentially, perhaps there *was* no stream to play.

 

I've no idea what I'm talking about when it comes to video streaming, but given the sequence of events and the slight difference in behaviour in iOS clients vs the tvOS client, I wonder if that's it.

 

The sequence in iOS is: go into new folder, each file says "loading details" - there is no thumbnail etc at this stage, and you can't tap on any video to play them. You have to wait til it's "loaded details" for the file you want to play. If you tap on a file while it's displaying "loading details", you simply get no response.

 

In tvOS, the sequence was: go into new folder, there's no "loading details" because the files were laid out in a grid; no thumbnails, cos this was the first time the client had touched the folder. I tapped on the first file in the list and got the above error message. A few seconds later I reversed back into the folder from the 'play' screen (with the error on it), and all the thumbnails were there and every video played perfectly.

 

So, hopefully it's just that I played too soon - maybe for UX purposes it would be good for there to be a delay built into the client to stop people getting errors if they're as impatient as I was :-)



#14 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 01 November 2015 - 12:41 PM

That is a possible explanation. I'll see if I can reproduce the problem.



#15 tvmaster

tvmaster

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 02 November 2015 - 12:11 AM

With the Apple TV 4 version, can I enter a public DNS server (No-IP.org, for example) and access my Windows-based servers files?  I do that now with the Apple IOS 9 version on my Ipad Air 2



#16 mrich

mrich

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 02 November 2015 - 04:34 AM

Getting a new error now that I've upgraded to 2.2.1u1 on the Air Video HD Server Preferences page- UPnP port mapping not possible. The server is not reachable directly from the internet. This wasn't an issue with the previous server version. How do I correct this?



#17 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 02 November 2015 - 10:55 AM

The port mapping error is unlikely caused by server update. Unfortunately UPnP is notoriously unreliable protocol and even worse router implementations tend to be really buggy. It often just stops working. Sometimes restarting the router (and then restarting Air Video Server HD) can help. Also just logging in to router settings can also help sometimes.


  • mrich likes this

#18 myndon

myndon

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 02 November 2015 - 08:21 PM

This version has been much more prone to max my cpu, spin up all fans, and hang that way until force quit. Logs being PMed now.

 

Server specs as follows:

 

Win 8 x64, core i7 3770, 16gb memory, P8Z77 asus mainboard with intel 4000 (hardware decode enabled as it was on the previous air video version), geforce gtx 970.



#19 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 02 November 2015 - 09:49 PM

Does that happen during playback or while server is idle? 



#20 myndon

myndon

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 02 November 2015 - 10:15 PM

CPU load occurs during playback, and some files seem to cause the server to hang for all sessions and peg the CPU until the server is killed and brought back up. I haven't found any pattern to the individual files that do this.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users