Jump to content


Photo

Air Video Server HD 2.1.3


  • Please log in to reply
60 replies to this topic

#41 ianmoncrieffe

ianmoncrieffe

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 11 May 2015 - 02:16 PM

ok i am having some issues. i paid for the early access feature. I have a chromecast that i have plugged into my work PC that is connected to our visitor wifi for the company. also this visitor wifi is what my iphone is connected to. it is pulling my tv shows that are on my home pc. i play the files fine on my iphone but i do not get the chromecast icon on my iphone to send it to my chromecast work pc monitor ?



#42 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 11 May 2015 - 06:16 PM

Hi,

 

do you see the chromecast icon in other apps? It is possible that your visitor network doesn't allow bonjour discovery.



#43 Beta

Beta

    Member

  • Members
  • PipPip
  • 11 posts

Posted 15 May 2015 - 09:48 AM

I have tested some more and the problems start with 2.1.1 beta 1. I have also ruled out the videocard driver. Windows 7 and windows 8.1 show the same results. I have played some more files and you see sometimes artifects. It's not that airvideo makes a crash. It just keep on playing. But i think the quality is less then previous version off airvideo. I know your waithing for logs but i have to screen them because off file names etc. So i just report it in the hope it get solved. I stay with version hd 2.1.0 beta3.
I can test for you the new versions and see if it's solved.

#44 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 15 May 2015 - 10:26 AM

Beta, please send the logs from Air Video Server HD (Create Archive from Logs) to support(at)inmethod.com . I can't solve the issues unless I know what they are exactly.



#45 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 125 posts

Posted 15 May 2015 - 01:17 PM

One thing I noticed with Chromecast (unlike Apple TV), I have to turn off the system settings for auto lock and cover lock / unlock on my iPad otherwise the video will stop playing after a short while. The video plays forever with these settings off. I have tested this several times. I have background app refresh in system settings and auto-play next video in Air Video HD turned on.

 

I don't know if anything can be done to make changing these lock settings unnecessary, that would be nice, but not  it's not a huge issue.

 

RMcV

 

iPad Air 2, iOS 8.3

Apple TV 3



#46 Beta

Beta

    Member

  • Members
  • PipPip
  • 11 posts

Posted 15 May 2015 - 02:27 PM

Beta, please send the logs from Air Video Server HD (Create Archive from Logs) to support(at)inmethod.com . I can't solve the issues unless I know what they are exactly.


send you the logs. Greetings beta.

#47 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 15 May 2015 - 03:34 PM

One thing I noticed with Chromecast (unlike Apple TV), I have to turn off the system settings for auto lock and cover lock / unlock on my iPad otherwise the video will stop playing after a short while. The video plays forever with these settings off. I have tested this several times. I have background app refresh in system settings and auto-play next video in Air Video HD turned on.

 

I don't know if anything can be done to make changing these lock settings unnecessary, that would be nice, but not  it's not a huge issue.

 

RMcV

 

iPad Air 2, iOS 8.3

Apple TV 3

 

Is this for local videos (downloaded to device) or playback from server? The playback should definitely continue with locked device, or even when app was terminated by system. Autoplay next will not work though, but it should continue as long as Air Video HD gets into foreground.

 

What happens when playback ends? Is the Air Video app still running on Chromecast or does it return to "default" app? If it does, try restarting the Chromecast.



#48 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 125 posts

Posted 16 May 2015 - 11:45 AM

I am talking about the playback from server scenario. It seems like your statement "The playback should definitely continue with locked device, or even when app was terminated by system. Autoplay next will not work though, but it should continue as long as Air Video HD gets into foreground." is correct. I have terminated the AVHD app and the video keeps on going. I have opened the iPad cover after a video has stopped and the next video starts up.

 

What I would like is that AVHD keeps playing videos until I terminate the app, cover closed and lock configs on, as it does with the Apple TV, but I have a feeling from your statement above that this is likely not possible.



#49 abat119

abat119

    Member

  • Members
  • PipPip
  • 22 posts

Posted 21 May 2015 - 07:58 PM

Question about transcoded audio and surround sound:

 

Hey there, I'm using v2.1.3 and noticed that DTS files are being converted to AC3 for my Apple TV and Stereo for my iPad (even with the 'surround sound' setting turned on). This is great, except now I'm wondering if my original AC3 audio is being RE-transcoded unnecessarily...

 

Here's the thing: I set up my codecs (Directshow on Windows) to bitstream my audio so that there won't be ANY unnecessary transcoding to get the highest quality possible. In previous versions of Air Video HD the DTS feed woudn't even play through the Apple TV and AC3 wouldn't play through the iPad (I'd get a crackling noise) - so this is the cause of my doubt...

 

I noticed also that the Directshow filters aren't even being used when playing a file (task manager) - where in previous versions of AVHD it did, and the CPU load is the same whether I play DTS or AC3 to my Apple TV - which, again, leads me to believe that it's transcoding the AC3 audio.

 

So what's up with that?

 

Thanks! : - )



#50 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 21 May 2015 - 08:01 PM

Original AC3 is always passed through for Apple TV (no transcoding), but at the same time it is transcoded to Stereo AAC for iPad (since iPad can not play AC3).



#51 abat119

abat119

    Member

  • Members
  • PipPip
  • 22 posts

Posted 21 May 2015 - 08:09 PM

Thanks! Just wanted to make sure.

 

Just a suggestion: if it would be possible to add an indication that AC3 will be passed through to Apple TV that would be great (just to clear things up a bit for the people who don't read the forums : - ) )



#52 minnepinne

minnepinne

    Member

  • Members
  • PipPip
  • 12 posts

Posted 23 May 2015 - 08:38 PM

Hi,

youtube is different. With youtube Chromecast streams from internet. With Air Video HD, Chromecast streams from your computer (that runs Air Video Server HD). For some reason in your case Chromecast is unable to connect to your computer. If you have a third party firewall, try temporarily disabling it. Or even system firewall if you don't have third party firewall software.

Is this only supposed to work on a local network? Not over internet? My phone is on the same wifi as the chromecast. Why would it be a firewall issue? Does chromecast have some internal firewall that I don't know about?

#53 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 31 May 2015 - 05:29 PM

Is this only supposed to work on a local network? Not over internet? My phone is on the same wifi as the chromecast. Why would it be a firewall issue? Does chromecast have some internal firewall that I don't know about?

 

Right now one of the issues is that Air Video HD encrypts all traffic outside local network, but it is not possible to play encrypted video on chromecast. We'll have to disable video encyption on Chromecast over remote WiFi, but that will require client update.



#54 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 31 May 2015 - 05:39 PM

2.1.4-beta4 released



#55 minnepinne

minnepinne

    Member

  • Members
  • PipPip
  • 12 posts

Posted 09 June 2015 - 06:06 PM

Right now one of the issues is that Air Video HD encrypts all traffic outside local network, but it is not possible to play encrypted video on chromecast. We'll have to disable video encyption on Chromecast over remote WiFi, but that will require client update.

Is there a plan to update the client with the option to turn off remote wifi encryption?

#56 admin

admin

    Administrator

  • Administrators
  • 2573 posts

Posted 09 June 2015 - 10:51 PM

Generally or just for chromecast? Chromecast playback should not be encrypted over remote wifi in next update, but all other traffic will still be encrypted.


  • minnepinne likes this

#57 minnepinne

minnepinne

    Member

  • Members
  • PipPip
  • 12 posts

Posted 10 June 2015 - 10:36 AM

Generally or just for chromecast? Chromecast playback should not be encrypted over remote wifi in next update, but all other traffic will still be encrypted.


I was thinking about chromecast. Hopefully the next update will come soon. :)

#58 kamijyo

kamijyo

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 02 October 2015 - 12:45 PM

Generally or just for chromecast? Chromecast playback should not be encrypted over remote wifi in next update, but all other traffic will still be encrypted.


Afetr all, we can't cast with AirVideo HD server on this version 2.1.4 ?
I want to watch on chromecast over remote wifi, but I have “Media failed to load” error.
Only the title and seek bar is shown, but it occurs error.

#59 alexjh

alexjh

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 04 October 2015 - 11:57 PM

Afetr all, we can't cast with AirVideo HD server on this version 2.1.4 ?
I want to watch on chromecast over remote wifi, but I have “Media failed to load” error.
Only the title and seek bar is shown, but it occurs error.

 

Any update on this?  I'm still unable to play to Chromecast over remote wifi.  "Media failed to load"

 

Please advise.



#60 NichUK

NichUK

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 28 January 2016 - 02:07 AM

I too am getting the Playback failed for xxxx.mp4  Media failed to load message whenever i try to cast to Chromecast.

 

I'm trying with downloaded files (since I'm away at present). Connecting remotely to my AirVideo server seems to work. That casts OK.

 

I'm on version 2.1.4 (build 201.04) of the app, obviously with Early Access subscribed and switched on.

 

Since it seems to work (although sometimes with no sound) when streaming, this definitely feels like a bug.

 

 

Nich






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users