Jump to content


Photo

Air Video Server HD 2.1.3


  • Please log in to reply
60 replies to this topic

#21 xavalin

xavalin

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 09 May 2015 - 04:49 PM

Thanks. So far I'm unable to reproduce this though. Could you maybe take photo of the subtitles? I'm not sure what's wrong. On all Chromecast devices that I have the subtitles show either white or yellow (depending on the settings).

How do I send a photo in here?.



#22 admin

admin

    Administrator

  • Administrators
  • 2579 posts

Posted 09 May 2015 - 04:50 PM

You can email it to me to support(at)inmethod.com



#23 xavalin

xavalin

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 09 May 2015 - 04:54 PM

You can email it to me to support(at)inmethod.com

Already sent.



#24 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 125 posts

Posted 09 May 2015 - 05:03 PM

@ admin: Good News and Bad News! :o

 

Good news - Chromecast works great!

 

Bad news - I can no longer see the icon for the Apple TV in your app on the left hand side of the same line that has the file info symbol. What I see is the Chromecast symbol and the video title only. Therefore I can no longer use my iPad Air 2 and Air Video HD to push the video to the Apple TV.

 

More Details: My wife's iPad 3 is working "properly" i.e. her AirVideo HD has the video title second line from the bottom and a Chromecast symbol and an Apple TV symbol beside it on the left hand side of the same line that has the file info symbol. She can push to both Chromecast and Apple TV. Both iPads have iOS 8.3.

 

To try to fix the problem (without success!) I have:

1) Restarted the server on the PC

2) Deleted the AirVideo HD app and reinstalled from the app store

3) Rebooted my iPad

4) Rebooted the Apple TV

5)Turned off the Early Access Features switch (All that happened was that the Chromecast symbol dissappeared too, so I turned it back on)

 

Please Help!

 

RMcV



#25 admin

admin

    Administrator

  • Administrators
  • 2579 posts

Posted 09 May 2015 - 05:04 PM

Hi,

 

the way this works, you need to disconnect from Chromecast first to see Apple TV. Tap on the chromecast icon and choose Disconnect.



#26 admin

admin

    Administrator

  • Administrators
  • 2579 posts

Posted 09 May 2015 - 05:05 PM

Actually, now I did read it all. If you turned off early access and it still doesn't work, it means there are bonjour issues. Are you able to select Apple TV from the iOS Control Center?



#27 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 125 posts

Posted 09 May 2015 - 06:58 PM

@ admin:

 

I was able to successfully connect the iPad to the Apple TV through the iOS system settings. I know I was not still connected to Chromecast because I remember seeing the orange disconnect in the Chromecast list and tapping it before I closed AVHD.

 

I rebooted my router and PC, then I used AVHD to connect to Chromecast. I ran a video for a few seconds, then disconnected from Chromecast and then the apple TV icon appeared. So hopefully everything is OK now, I will let you know.

 

RMcV



#28 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 125 posts

Posted 09 May 2015 - 07:15 PM

I think I understand now... the Chromecast symbol always shows up right from the beginning no activity required...however!... the Apple TV symbol ONLY shows up AFTER you start the video file.

 

In my opinion, the two symbols should either show up right from the beginning or worst case scenario, the two symbols show up after you start the video file.

 

Please let me know your thoughts on this.

 

Thanks,

 

RMcV



#29 Sunrise

Sunrise

    Advanced Member

  • Members
  • PipPipPip
  • 116 posts

Posted 09 May 2015 - 07:18 PM

I'm suddenly getting Air Video HD server crashes with 2.1.3.

 

Tried the new client (2.1.0) and the new server 2.1.3 today for only about 30 minutes and it crashed two times.

 

Not sure how to reliably reproduce it though, I originally just wanted to see what new features you added (16 ref. frames working great, thanks a lot!) and I played only 5 of my usual files that I always test with each new Air Video HD release within these 30 minutes.

 

I played around with the new 20mbit preset and switched between 10mbit and 20mbit presets while playing some files, then I also tried the new surround sound switch and turned it on and off.

 

I then played two 3840x2160 MP4 files (one with 5.1 AC3 surround, the other is stereo) and after the first one completed suddenly I couldn't connect to the server anymore. It always showed "Loading..." first, after about 3 tries to play again, I closed the app and started the app again on my iphone 5s. When I clicked on the "SERVERNAME - available on local network" button I suddenly get an error that I didn't ever see before "Error occured while resolving server address. Server is offline!"

 

I then went to my PC desktop and it showed a crash message "Air Video HD stopped working". Afterwards I looked at the Air Video HD server logs, unfortunately there's nothing in them, no crash message, nothing at all.

 

I have attached you the two screenshots:

 

airvideohd_2.1.3_erroyuuqn.pngairvideohd_2.1.3_errohiu7k.png

 

I am a bit lost, not sure how I can narrow it down. Do you have any idea what you introduced that could cause a hard crash of the server? And why would Air Video HD client still say "available on local network"?



#30 admin

admin

    Administrator

  • Administrators
  • 2579 posts

Posted 09 May 2015 - 07:22 PM

That's a good point. The current behavior is obviously confusing otherwise you wouldn't have spent time restarting your devices :)

 

The chromecast button is important when the app is running on chromecast, as it is the only way to disconnect and return to chromecast homescreen. So I decided to always show the button. But it seems to cause problems.

 

So at this point there are two options.

 

1. Only show chromecast button right from the beginning when connected (chromecast app is running) - to allow user to close the app on chromecast

 

2. Display both AirPlay and Chromecast button right from the beginning.



#31 admin

admin

    Administrator

  • Administrators
  • 2579 posts

Posted 09 May 2015 - 07:23 PM

Sunrise, there are no crash logs. However the stacktrace should be reported to our crash server. You can send me the logs from Air Video Server HD and I'll try to look up the crashlog. Are the crashes reproducible?



#32 Sunrise

Sunrise

    Advanced Member

  • Members
  • PipPipPip
  • 116 posts

Posted 09 May 2015 - 07:35 PM

Sunrise, there are no crash logs. However the stacktrace should be reported to our crash server. You can send me the logs from Air Video Server HD and I'll try to look up the crashlog. Are the crashes reproducible?

 

Just sent you the logs "airvideohd_server_2.1.3_crash_logs.zip". Password for the archive is "airvideohd".

 

I cannot reproduce the crashes at the moment, I am watching something with a friend.



#33 lemlowx

lemlowx

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 10 May 2015 - 08:58 AM

@ admin,

 

Have been using since air video 1. Purchased the early access feature immediately as support to the great job you have been doing with this app!. 



#34 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 125 posts

Posted 10 May 2015 - 12:36 PM

@ admin:

 

I'm glad you got a chuckle out my resetting everything. :lol:

 

Of your two options, my personal preference is to show both.

 

I have to say this is the best implementation of Chromecast video functionality that I have seen. You have brought the quality you have in place for the Apple TV to Chromecast.

 

RMcV



#35 duceduc

duceduc

    Member

  • Members
  • PipPip
  • 13 posts

Posted 10 May 2015 - 12:41 PM

I can't seem to get 2.1.3 to work. Upgrading from 2.1.1 beta2 which works fine. The server is asking me to download VLC because codec AC3 isn't detected. I've have VLC 2.2.1 installed, but it still say codec AC3 is missing. 

Revert back to Airvideo HD 2.1.1 Beta2  and all is fine again. 



#36 minnepinne

minnepinne

    Member

  • Members
  • PipPip
  • 12 posts

Posted 10 May 2015 - 01:33 PM

Signed up for early access to get chromecast. But when I try it I get the error "media failed to load".
Is this a known error? Any known solution?
It plays well on my iPhone and to Apple tv.

#37 admin

admin

    Administrator

  • Administrators
  • 2579 posts

Posted 10 May 2015 - 02:30 PM

I can't seem to get 2.1.3 to work. Upgrading from 2.1.1 beta2 which works fine. The server is asking me to download VLC because codec AC3 isn't detected. I've have VLC 2.2.1 installed, but it still say codec AC3 is missing. 

Revert back to Airvideo HD 2.1.1 Beta2  and all is fine again. 

 

Do you have 32 or 64bit Air Video Server HD? You need matching VLC as well. I.e. 64bit server will only work with 64bit VLC.



#38 admin

admin

    Administrator

  • Administrators
  • 2579 posts

Posted 10 May 2015 - 02:32 PM

Signed up for early access to get chromecast. But when I try it I get the error "media failed to load".
Is this a known error? Any known solution?
It plays well on my iPhone and to Apple tv.

It's not a known error. Does it happen with all your files? Does it happen when you enable 'Force Conversion' option in Info menu [ ( i ) on iPhone ]? If so, it could be a firewall issue. I've seen the error when Chromecast was unable to get video data from the computer (firewall was blocking the connection).



#39 minnepinne

minnepinne

    Member

  • Members
  • PipPip
  • 12 posts

Posted 10 May 2015 - 03:21 PM

It's not a known error. Does it happen with all your files? Does it happen when you enable 'Force Conversion' option in Info menu [ ( i ) on iPhone ]? If so, it could be a firewall issue. I've seen the error when Chromecast was unable to get video data from the computer (firewall was blocking the connection).


Yeah. It happens on all the files I tried. Same error when I enabled Force Conversion. Restarted the server. And all files play nice on the Air Video app on this network. YouTube app streams to the chromecast just fine.

#40 admin

admin

    Administrator

  • Administrators
  • 2579 posts

Posted 10 May 2015 - 03:26 PM

Yeah. It happens on all the files I tried. Same error when I enabled Force Conversion. Restarted the server. And all files play nice on the Air Video app on this network. YouTube app streams to the chromecast just fine.

Hi,

 

youtube is different. With youtube Chromecast streams from internet. With Air Video HD, Chromecast streams from your computer (that runs Air Video Server HD). For some reason in your case Chromecast is unable to connect to your computer. If you have a third party firewall, try temporarily disabling it. Or even system firewall if you don't have third party firewall software.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users