Jump to content


Photo

Air Video Server HD for Linux


  • Please log in to reply
292 replies to this topic

#21 marioscube

marioscube

    Member

  • Members
  • PipPip
  • 12 posts

Posted 08 December 2014 - 08:17 PM

Do you have  dbus-uuidgen on Mint16? Have you tried running it (as root probably)? It should create /var/lib/dbus/machine-id file that dbus needs. We use dbus to communicate with avahi to configure bonjour.

 

/var/lib/dbus/machine-id is/was available on mint 16 (and mint 17) system.

 

Ran dbus-uuidgen (as root).

 

No change. I still get the error:

 

D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/etc/machine-id": No such file or directory 

 

On Mint 16 and mint 17 (that works) there is no file "/etc/machine-id".

 

Any thoughts on this?



#22 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 08 December 2014 - 08:21 PM

/etc/machine-id is tried only after /var/lib/dbus/machine-id is not found. I'm not quite sure why it doesn't find it. i assume you have permissions to read the file? Does it make any difference if you make a symlink from /var/lib/dbus/machine-id to /etc/machine-id ?



#23 marioscube

marioscube

    Member

  • Members
  • PipPip
  • 12 posts

Posted 08 December 2014 - 08:39 PM

/etc/machine-id is tried only after /var/lib/dbus/machine-id is not found. I'm not quite sure why it doesn't find it. i assume you have permissions to read the file? Does it make any difference if you make a symlink from /var/lib/dbus/machine-id to /etc/machine-id ?

 

I run a ssh-terminal as root. No problems with permissions.

 

symlink = no difference.



#24 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 08 December 2014 - 08:53 PM

So even if you symlink the file to /etc/machine-id the server still complains about not being able to read the machine-id? That's really weird.



#25 marioscube

marioscube

    Member

  • Members
  • PipPip
  • 12 posts

Posted 08 December 2014 - 09:15 PM

AirVideoServerHD crashes the moment it has to create thumbnails from the media files.

 

Maybe it has something to do with my processor: Intel Celeron 1820

 

It has no video hardware acceleration. (HD2500)

 

But it should do Software/CPU conversions.



#26 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 08 December 2014 - 09:20 PM

The CPU shouldn't be a problem. Also linux version does not currently do hardware acceleration.

 

What VLC version do you have installed? Are there any updates available?

 

Getting us a core dump would be very helpful here.



#27 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 08 December 2014 - 09:23 PM

Actually, there are logs in ~/AirVideoServerHD/Logs, you can email those to support(at)inmethod.com



#28 marioscube

marioscube

    Member

  • Members
  • PipPip
  • 12 posts

Posted 08 December 2014 - 09:37 PM

Found the problem!

 

VLC version = 2.0.8-1

 

This is the most recent version in the distribution-packages for Linux Mint 16

 

VLC in Linux Mint 17 = 2.1.4 

 

(Bummer, I did not want to upgrade my main server yet. Maybe later this month)



#29 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 08 December 2014 - 09:39 PM

2.0.8 should work actually. If you manage to get core dump after the crash I can take a look at it.



#30 marioscube

marioscube

    Member

  • Members
  • PipPip
  • 12 posts

Posted 08 December 2014 - 11:11 PM

If I can figure out how to make a core-dump I will do that sometime tomorrow (it's getting late over here, I need my zzzzz's ;)  )

 

Thank you helping out!



#31 ghorman

ghorman

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 08 December 2014 - 11:41 PM

I get the server started but I can't connect to it.  I have turned off iptables and selinux.

 

 

 

Steps.

1. Iphone finds the linux Airvideo 
(after first is ask for a Remote server ID, which i had to pull from the logs)

2. Trys to Resolving Connection

3. Error occurred while resolving server address.

 

Next I added the server by IP: 192.168.0.107:45633

Error: Could not connect to the server.

 

I'm starting the ./start.sh as root.

 

Any help would be great.

 

Edited:  Looks like I still had a firewall issue.  I got it now.


Edited by ghorman, 08 December 2014 - 11:51 PM.


#32 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 08 December 2014 - 11:50 PM

Try navigating to http://192.168.0.107:45633/verifyin iPhone Safari. If you can't connect even using safari, it means something is blocking you.



#33 IceIceBird

IceIceBird

    Member

  • Members
  • PipPip
  • 26 posts

Posted 09 December 2014 - 01:32 AM

Suggestions.

  • If no --config is defined the server should use 'Server.properties' file if present as defualt config file, if not found show error message.
  • I also agree to what lstein said, "the ability to change the location of the log, runtime data and cache files".
  • Some sort of minimal gui or systray. Start/Stop/Exit and some smal info telling us that it's up and running.
    and of course the --nogui option for those who needs that ;)

I know the Linux version of the server is only in alpha stage but I'm so excited that we are finaly here ;) ;) :D



#34 root

root

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 09 December 2014 - 02:30 AM

You mean something for /etc/init.d? We don't have one but it shouldn't be too difficult to write, maybe someone can contribute one? :)

 

I actually spent an hour writing it. Got it working to the extend that the process would start at boot, and start, restart, and stop using "service airvideo <start, restart, stop>". However, the server constantly crashes.

I see that Istein has posted his own creation. I will try it out. :-)



#35 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 09 December 2014 - 02:37 AM

 However, the server constantly crashes.

If the server constantly I'd need a core dump and logs (from ~/.AirVideoServerHD/Logs). Also which VLC version do you have installed?



#36 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 09 December 2014 - 02:39 AM

  • If no --config is defined the server should use 'Server.properties' file if present as defualt config file, if not found show error message.
  • I also agree to what lstein said, "the ability to change the location of the log, runtime data and cache files".
  • Some sort of minimal gui or systray. Start/Stop/Exit and some smal info telling us that it's up and running.
    and of course the --nogui option for those who needs that ;)

Default config makes sense, I'm not convinced about the GUI. Perhaps as another executable.



#37 Spasitel

Spasitel

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 09 December 2014 - 01:28 PM

Does your plan include creating an ARM build? I was waiting for linux release of AirVideo HD for two reasons: ARM and video acceleration.



#38 admin

admin

    Administrator

  • Administrators
  • 2584 posts

Posted 09 December 2014 - 01:33 PM

Does your plan include creating an ARM build? I was waiting for linux release of AirVideo HD for two reasons: ARM and video acceleration.

What do you want to deploy it on? ARM build makes sense of course, but only if we have hardware accelerated transcoding covered on that platform.



#39 IceIceBird

IceIceBird

    Member

  • Members
  • PipPip
  • 26 posts

Posted 09 December 2014 - 03:38 PM

Default config makes sense, I'm not convinced about the GUI. Perhaps as another executable.

Yes thats exactly what I would want (and probably some others), a desktop executable GUI as an alternative to sh file.

 

Edit:
Oh and by the way, I've been waiting and longing a long time to have rar suport. Is this something we will see in the future? ;)
That's actuallt the only thing missing for me right now.



#40 marioscube

marioscube

    Member

  • Members
  • PipPip
  • 12 posts

Posted 10 December 2014 - 01:17 PM

I have just sent an e-mail to support (at) inmethod.com regarding my crash issue with Linux Mint 16

 

Linux MInt 17 works fine.

 

Thanx for your help. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users