Jump to content


Photo

Air Video Server HD for Linux


  • Please log in to reply
292 replies to this topic

#181 frl

frl

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 10 May 2015 - 01:54 PM

Cheers - I've disabled UPNP on my router for now and the server is working really well other than this issue.

 

Look forward to a fix, thanks again for the efforts on the linux server!



#182 kley2014

kley2014

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 10 May 2015 - 02:17 PM

I am a big fan of Air Video. I have it in my PC and iPhone. I just bought a Synology DS415+ NAS Sever. Is it possible to install the sever in the NAS? If yes, can you please show me the steps? 



#183 KorP

KorP

    Member

  • Members
  • PipPip
  • 28 posts

Posted 13 May 2015 - 03:52 PM

Constantly failing how? You need to be more specific. What doesn't work?

So I wanted to check out the logs that would give more specifics, but new logs I have something I can not quite make out. Most often, the server crashes at the start of a new file playback. Lay down on the couch, turned on, and then - the server is not available

 

And the brakes again continuing, despite the fact that the sale of reduced bit rate. Judging by the schedules zabbiks - the server is running correctly and the network continues to code loaded as well, really still a problem with the two tablets, or access point. It is impossible to determine how that - for whatever reason stop video playback - brake system, or the client can not take the flow?



#184 erico.bettoni

erico.bettoni

    Member

  • Members
  • PipPip
  • 13 posts

Posted 14 May 2015 - 03:48 PM

I am a big fan of Air Video. I have it in my PC and iPhone. I just bought a Synology DS415+ NAS Sever. Is it possible to install the sever in the NAS? If yes, can you please show me the steps? 

Do you know which processor your synology uses? By the description looks like an entry level 4 drive NAS. If thats the case it has an underpowered ARM processor, which will not run AirVideo, even if an ARM build is released...



#185 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 14 May 2015 - 05:51 PM

Any NAS that would even be considered to port server to must have dedicated video encoder/decoder hardware. DS-451 does not have that.



#186 erico.bettoni

erico.bettoni

    Member

  • Members
  • PipPip
  • 13 posts

Posted 14 May 2015 - 06:12 PM

Any NAS that would even be considered to port server to must have dedicated video encoder/decoder hardware. DS-451 does not have that.

 

What about FreeBSD? Have you read my msgs in the last page? Can I help in any way?



#187 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 15 May 2015 - 06:37 PM

What about FreeBSD? Have you read my msgs in the last page? Can I help in any way?

 

I have read the messages. Right now I'm not sure what it would take to do BSD build. Biggest hurdle we have with linux are related to old distribution with old libc versions, I assume BSD situation will be similar? Which FreeBSD version would we need to support?



#188 kley2014

kley2014

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 17 May 2015 - 12:34 AM

Do you know which processor your synology uses? By the description looks like an entry level 4 drive NAS. If thats the case it has an underpowered ARM processor, which will not run AirVideo, even if an ARM build is released...

I think the processor in this one is pretty powerful and it can handle it. Here are the specs: 
 

DS415+
CPU
INTEL Atom C2538
CPU clock rate
2.4 GHz
CPU cores
4
Total physical memory
2048 MB


#189 erico.bettoni

erico.bettoni

    Member

  • Members
  • PipPip
  • 13 posts

Posted 18 May 2015 - 02:12 PM

I have read the messages. Right now I'm not sure what it would take to do BSD build. Biggest hurdle we have with linux are related to old distribution with old libc versions, I assume BSD situation will be similar? Which FreeBSD version would we need to support?

 

You need to support only 10.x, which is the latest release. Also, FreeBSD doesnt have multiple distros, things are much more standardized than on the linux world.



#190 erico.bettoni

erico.bettoni

    Member

  • Members
  • PipPip
  • 13 posts

Posted 18 May 2015 - 02:15 PM

 

I think the processor in this one is pretty powerful and it can handle it. Here are the specs: 
 

DS415+
CPU
INTEL Atom C2538
CPU clock rate
2.4 GHz
CPU cores
4
Total physical memory
2048 MB

 

 

That's more powerful than what I would have expected! Can you login via telnet/ssh and run 'uname -a' ?



#191 KorP

KorP

    Member

  • Members
  • PipPip
  • 28 posts

Posted 20 May 2015 - 09:29 PM

admin

because you can still test the server and client that to understand - what exactly is the problem with the brakes?It may be you can open a video then from the server to your computer and see whether the brakes? or may be in the client you can see the process of loading the data? or from the server? logs on the server I looked but did not find anything, what could be attached.



#192 Xtropy

Xtropy

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 25 May 2015 - 08:11 PM

Is anyone having issues with AAC audio transcoding on their Linux server? I have an Ubuntu NAS running 14.0.4.2 with VLC 2.2.1 (headless SSH only). Installed the AirServer Linux server and all video work EXCEPT those that have AAC audio. When I try to play any video with AAC audio, the server crashes. I can play DTS-MA 7.1 and 1080p perfectly so not sure why AAC is an issue. Here are the logs I could find when I try to play a video with AAC. The "Segmentation fault (core dumped)" comes up as soon as I play the video file with AAC otherwise it stays as the port listed. If I download the original stream to my iPhone, it plays perfectly but as soon as any transcoding is involved, the server crashes. Any suggestions to resolve?
 
I have tried getting coredumps working and nothing is generated even after increasing the limit to unlimited.
 
 
#####@ubuntuNAS:/usr/local/sbin/AirVideo$ ./start.sh
 
GST_PLUGIN_SCANNER=/usr/local/sbin/AirVideo/Resources/bin/gst-plugin-scanner
Local server started at port 45601
Main server started at port 45633
Segmentation fault (core dumped)
 
apport.log:
 
ERROR: apport (pid 11361) Wed May 13 09:18:34 2015: called for pid 13338, signal 11, core limit 18446744073709551615
ERROR: apport (pid 11361) Wed May 13 09:18:34 2015: ignoring implausibly big core limit, treating as unlimited
ERROR: apport (pid 11361) Wed May 13 09:18:34 2015: executable: /usr/local/sbin/AirVideo/AirVideoServerHD (command line "/usr/local/sbin/AirVideo/AirVideoServerHD --config=Server.properties")
ERROR: apport (pid 11361) Wed May 13 09:18:34 2015: executable does not belong to a package, ignoring
 
kern.log
 
May 13 09:18:34 ubuntuNAS kernel: [420613.805270] multiqueue1:src[11360]: segfault at 13 ip 00007f7e6245f521 sp 00007f7e2cff82c0 error 4 in libglib-2.0.so.0[7f7e62443000+f9000]
 
external-encoder.log:
 
2015-05-13 09:18:34:925 rpc.server               [I] Stopping Server Write Thread.
2015-05-13 09:18:34:925 rpc.server               [I] Stopping Server Read Thread.
2015-05-13 09:18:34:925 rpc.bootstrap            [I] Server Stopped
 
transcoding.live.log
 
09:18:34 INFO  03 transcoding.manager TranscodingManager.cpp:1156 - Initializing live transcoding for '/mnt/samba/Media/TV/100, The/Season 01/The 100 - S01E01 - Pilot.mp4'
09:18:34 INFO  03 transcoding.manager TranscodingManager.cpp:751  - Creating topology for video: 448, audio: none, audio alt: 64
09:18:34 DEBUG 03 transcoding.manager TranscodingManager.cpp:779  - Topology - creating video stream video_0
09:18:34 DEBUG 03 transcoding.manager TranscodingManager.cpp:812  - Topology - creating video transcoding branch (448)
09:18:34 DEBUG 03 transcoding.manager TranscodingManager.cpp:854  - Topology - creating audio stream audio_0
09:18:34 DEBUG 03 transcoding.manager TranscodingManager.cpp:869  - Topology - creating audio transcoding branch (64)
09:18:34 DEBUG 03 transcoding.manager TranscodingManager.cpp:1250 - Created transcoding session: /live-transcoding/playlist/session2-8ea4d3ce-f972-11e4-a25c-f0def13eb38c/master.m3u8
09:18:34 INFO  03 transcoding.transcoder GstLiveTranscoder.cpp:31 - Creating transcoder for '/mnt/samba/Media/TV/100, The/Season 01/The 100 - S01E01 - Pilot.mp4' with initial offset 0.000000s
09:18:34 WARN  03 gst.basesrc gstbasesrc.c:3480 - - - - - - - - - - pad not activated yet
09:18:34 FIXME 03 gst.default gstutils.c:3697 - - - - - - - - - - - Creating random stream-id, consider implementing a deterministic way of creating a stream-id
09:18:34 WARN  03 gst.typefind gsttypefindelement.c:782 - - - - - - failed to query peer uri
09:18:34 WARN  03 gst.qtdemux qtdemux_types.c:202 - - - - - - - - - unknown QuickTime node type iods
09:18:34 WARN  03 gst.basesrc gstbasesrc.c:2391 - - - - - - - - - - processing at or past EOS
09:18:34 FIXME 03 gst.default gstutils.c:3697 - - - - - - - - - - - Creating random stream-id, consider implementing a deterministic way of creating a stream-id
09:18:34 FIXME 03 gst.default gstutils.c:3697 - - - - - - - - - - - Creating random stream-id, consider implementing a deterministic way of creating a stream-id


#193 omf

omf

    Member

  • Members
  • PipPip
  • 10 posts

Posted 27 May 2015 - 04:38 PM

I just installed the server last night on a NAS box I built using Debian 8 (Jessie) and haven't had any problems.  I did set the path locations to system-standard folders using the options in the Server.properties file. 

 

Xtropy: Most of my files use AAC audio and I haven't had any problems.



#194 Xtropy

Xtropy

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 31 May 2015 - 07:36 PM



 

Is anyone having issues with AAC audio transcoding on their Linux server? I have an Ubuntu NAS running 14.0.4.2 with VLC 2.2.1 (headless SSH only). Installed the AirServer Linux server and all video work EXCEPT those that have AAC audio. When I try to play any video with AAC audio, the server crashes. I can play DTS-MA 7.1 and 1080p perfectly so not sure why AAC is an issue. Here are the logs I could find when I try to play a video with AAC. The "Segmentation fault (core dumped)" comes up as soon as I play the video file with AAC otherwise it stays as the port listed. If I download the original stream to my iPhone, it plays perfectly but as soon as any transcoding is involved, the server crashes. Any suggestions to resolve?
 
I have tried getting coredumps working and nothing is generated even after increasing the limit to unlimited.
 
 
#####@ubuntuNAS:/usr/local/sbin/AirVideo$ ./start.sh
 
GST_PLUGIN_SCANNER=/usr/local/sbin/AirVideo/Resources/bin/gst-plugin-scanner
Local server started at port 45601
Main server started at port 45633
Segmentation fault (core dumped)
 
apport.log:
 
ERROR: apport (pid 11361) Wed May 13 09:18:34 2015: called for pid 13338, signal 11, core limit 18446744073709551615
ERROR: apport (pid 11361) Wed May 13 09:18:34 2015: ignoring implausibly big core limit, treating as unlimited
ERROR: apport (pid 11361) Wed May 13 09:18:34 2015: executable: /usr/local/sbin/AirVideo/AirVideoServerHD (command line "/usr/local/sbin/AirVideo/AirVideoServerHD --config=Server.properties")
ERROR: apport (pid 11361) Wed May 13 09:18:34 2015: executable does not belong to a package, ignoring
 
kern.log
 
May 13 09:18:34 ubuntuNAS kernel: [420613.805270] multiqueue1:src[11360]: segfault at 13 ip 00007f7e6245f521 sp 00007f7e2cff82c0 error 4 in libglib-2.0.so.0[7f7e62443000+f9000]
 
external-encoder.log:
 
2015-05-13 09:18:34:925 rpc.server               [I] Stopping Server Write Thread.
2015-05-13 09:18:34:925 rpc.server               [I] Stopping Server Read Thread.
2015-05-13 09:18:34:925 rpc.bootstrap            [I] Server Stopped
 
transcoding.live.log
 
09:18:34 INFO  03 transcoding.manager TranscodingManager.cpp:1156 - Initializing live transcoding for '/mnt/samba/Media/TV/100, The/Season 01/The 100 - S01E01 - Pilot.mp4'
09:18:34 INFO  03 transcoding.manager TranscodingManager.cpp:751  - Creating topology for video: 448, audio: none, audio alt: 64
09:18:34 DEBUG 03 transcoding.manager TranscodingManager.cpp:779  - Topology - creating video stream video_0
09:18:34 DEBUG 03 transcoding.manager TranscodingManager.cpp:812  - Topology - creating video transcoding branch (448)
09:18:34 DEBUG 03 transcoding.manager TranscodingManager.cpp:854  - Topology - creating audio stream audio_0
09:18:34 DEBUG 03 transcoding.manager TranscodingManager.cpp:869  - Topology - creating audio transcoding branch (64)
09:18:34 DEBUG 03 transcoding.manager TranscodingManager.cpp:1250 - Created transcoding session: /live-transcoding/playlist/session2-8ea4d3ce-f972-11e4-a25c-f0def13eb38c/master.m3u8
09:18:34 INFO  03 transcoding.transcoder GstLiveTranscoder.cpp:31 - Creating transcoder for '/mnt/samba/Media/TV/100, The/Season 01/The 100 - S01E01 - Pilot.mp4' with initial offset 0.000000s
09:18:34 WARN  03 gst.basesrc gstbasesrc.c:3480 - - - - - - - - - - pad not activated yet
09:18:34 FIXME 03 gst.default gstutils.c:3697 - - - - - - - - - - - Creating random stream-id, consider implementing a deterministic way of creating a stream-id
09:18:34 WARN  03 gst.typefind gsttypefindelement.c:782 - - - - - - failed to query peer uri
09:18:34 WARN  03 gst.qtdemux qtdemux_types.c:202 - - - - - - - - - unknown QuickTime node type iods
09:18:34 WARN  03 gst.basesrc gstbasesrc.c:2391 - - - - - - - - - - processing at or past EOS
09:18:34 FIXME 03 gst.default gstutils.c:3697 - - - - - - - - - - - Creating random stream-id, consider implementing a deterministic way of creating a stream-id
09:18:34 FIXME 03 gst.default gstutils.c:3697 - - - - - - - - - - - Creating random stream-id, consider implementing a deterministic way of creating a stream-id

 

 

 

Issue fixed after running: sudo apt-get purge libavutil52 and re-installing VLC. Thanks for the help Matej



#195 johnnymoped

johnnymoped

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 05 June 2015 - 10:08 AM

Guys, that all sounds very promising.

Great work!

 

I have debian chroot running on a Synology NAS (DS214play).

So a 32bit version would be great, to give it a try.

I for myself don't even need the transcoding feature. Direct play would be enough for my needs. So I don't worry about the CPU power (1.6GHz dual core Intel Atom).

In the future one could try to build a special version for this NAS's extra transcoding processor (capable of 1080p live encoding), but for now just a "simple" 32bit version would be awesome.

 

thanks 

 

daniel



#196 mika

mika

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 13 June 2015 - 08:18 AM

Hello,

 

I tried to install into a Raspbian (Debian for Raspberry pi ) Airvideo with the link given on the first post.

 

Unfortunatly, I'm having this issue while doing sudo ./start.sh  :

 

./AirVideoServerHD: 11: ./AirVideoServerHD: Syntax error: "(" unexpected

 

I tried to read that file, but it's full of wierd things.

 

Can someone help me ?

 

Thanks



#197 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 15 June 2015 - 07:40 AM

Air Video Server HD is a binary, but wrong architecture. It's built for x86, it can't be run on ARM.



#198 frl

frl

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 16 June 2015 - 06:30 AM

Hi admin,

 

Any word on fixing the issue with external access being enabled, even when it isn't?

 

Cheers,

frl


  • gyre likes this

#199 mika

mika

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 18 June 2015 - 10:25 AM

Air Video Server HD is a binary, but wrong architecture. It's built for x86, it can't be run on ARM.

 

Thank you for your answer. Did you think about that matter already ? :unsure:



#200 gers1978

gers1978

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 27 June 2015 - 05:11 PM

I've managed to download Air Video Server HD to my seedbox slot, which is Linux based.

 

I've got it running, and can access it from the AirVideo app, however I'm logged in to my remote seedbox slot via SSH using Terminal on my Mac, and I've started Air Video Server running using:

 

bash start.sh

 

Problem is, as soon as I quit Terminal on my Mac, I can no longer access the Air Video Server using the iPhone app

 

Any ideas?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users