Jump to content


Photo

Italic subtitles not showing

Italic Subtitles not showing UTF-8 UTF8 mkv matroska

  • Please log in to reply
3 replies to this topic

#1 Baraka13

Baraka13

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 04 October 2014 - 05:48 AM

Greetings community,

 

I'm having some trouble with italic lines in subtitles. I'ma explain below:

 

- Sever = MacbookPro Mavericks running AirVideo Server HD 2.0.2 (current version at this time);

- Client = iPhone 5 iOS 8.0.2 non-JB with AirVideo HD 2.0 installed (also current version at this time).

 

- Video = any Matroska video file;

- Subtitle = any UTF-8 encoded .srt file with italic lines and muxed (with mkvtoolnix) into the .mkv.

 

this paragraph below (in italic) is not so important, it is just explaining my situation so you won't come with rude responses

---So here's what's happening...I'm muxing all my movies and tv shows with the subtitles so that I can watch them on my TV through my home theatre (which is capable of reading these mkv files, but the subs have to be within the mkv files otherwise it won't be able to show it) and after testing all the possible sub encoding, I've discovered that the only one that works fine for my language (portuguese, PT-BR) is the UTF-8, so I also have to convert those, because they all came in ISO8859-1.---

 

When I stream the movies with external .srt subtitles, the italic lines shows perfectly fine, whether it is UTF-8 or ISO8859-1 encoded, so I don't think the encoding is the problem here.

 

But once I mux the sub inside the mkv file, the italic lines stop showing. Now, you might think "so the problem is the muxing", but when I play it on my computer (VLC player) or on my tv through my home theatre, these lines shows perfectly fine, so it only happens when streaming with AirVideo.

 

Any ideas on how to make these leaning little bastards to pop out on my tiny screen?

 

Thanks in advance, hope you could understand the whole thing.



#2 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 04 October 2014 - 09:33 PM

Hi,

 

I'd need to have a sample file for this. I you are able to provide one you can upload it here

 

www.mediafire.com/filedrop/filedrop_hosted.php?drop=7900c071f9970ec07e5c2ea0370a15d31aa421bab4923c42154ce133b8c0cb0b



#3 Baraka13

Baraka13

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 05 October 2014 - 02:51 AM

Hi, 

 

I have just uploaded a 14.2 MB sample of a muxed mkv file and its external UTF-8 encoded .srt file to the link above. Hope you can solve this for me.  :)

 

Thanks for the fast reply, you guys are pros.

 

BTW, you did a great...no, an AMAZING job with the revamped new iphone app, it's so much faster, smooth and beautifully designed. clap clap clap.



#4 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 05 October 2014 - 09:40 PM

Thanks for the file. It should be fixed in next server update.







Also tagged with one or more of these keywords: Italic, Subtitles, not showing, UTF-8, UTF8, mkv, matroska

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users