Jump to content


Photo

Air Video Server HD 2.0.0-beta2


  • Please log in to reply
17 replies to this topic

#1 admin

admin

    Administrator

  • Administrators
  • 2582 posts

Posted 06 September 2014 - 04:30 PM

Air Video Server HD  2.0.0-beta2 is available. 

 

Changes since beta-1

  • Fixed subtitle loading where subtitle file name case doesn’t match original file
  • Fixed conversion state not being updated when the queue gets too long
  • Fixed issue with SMI subtitle loader
  • Fixed issue with the client sometimes not showing last visited folder 
  • Fixed playback of certain Mpeg TS files

 

Changes since 1.0.15

  • Detect H.264 Level 5.2 properly
  • 64-bit Windows build
  • Fixed ExternalEncoder related error when shutting down Windows
  • Show correct sample rate for SBR AAC
  • Playback should be less likely to lock-up during seeking
  • Better way to deal with audio stream discontinuities (that could have resulted in A/V sync issues in certain streams)
  • Fixed seeking in some WTV files
  • Improved support for some MpegTS files
  • Fixed conversion getting stuck with certain subtitle files
  • Various bugfixes
  • Added features required for upcoming client update
  • Dark mode icon for Yosemite

 

Download for Mac OS X (universal)


  • Agrikpen likes this

#2 tdoane78

tdoane78

    Advanced Member

  • Members
  • PipPipPip
  • 140 posts

Posted 07 September 2014 - 12:51 PM

Installed and playing with it now.

 

-Tim



#3 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 126 posts

Posted 08 September 2014 - 11:06 AM

Beta2 is working fine.



#4 Hwinter

Hwinter

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 09 September 2014 - 04:29 PM

I installed, but I got an codec error for a movie I could previously play with version 1.0.15.

Note:

  • I have VLC 2.1.5 installed, and I even re-installed VLC but the error persisted.
  • Rolled back to 1.0.15 and it worked fine.

 

encoding-client.log

2014-09-09 12:06:57:810 rpc.encoder-process      [E] Could not read length, encoder has quit.
2014-09-09 12:06:57:811 rpc.encoder-process      [I] Stopping Write Thread.
2014-09-09 12:06:57:812 rpc.encoder-process      [I] Child process was running for 509.665037s, return code: 0
2014-09-09 12:06:57:813 rpc.encoder-process      [I] Stopping Write Thread.
2014-09-09 12:07:01:347 rpc.encoder-process      [I] Starting C:\Program Files\AirVideoServerHD\ExternalEncoder.exe (C:\Users\user\AppData\Local\AirVideoServerHD\Logs\external-encoder.log, C:\Users\user\AppData\Local\AirVideoServerHD\Cache\ExternalEncoder)
2014-09-09 12:07:01:358 rpc.encoder-process      [I] Starting Write Thread.
2014-09-09 12:07:01:358 rpc.encoder-process      [I] Starting Read Thread.
2014-09-09 12:10:24:391 rpc.encoder-process      [I] Starting C:\Program Files\AirVideoServerHD\ExternalEncoder.exe (C:\Users\user\AppData\Local\AirVideoServerHD\Logs\external-encoder.log, C:\Users\user\AppData\Local\AirVideoServerHD\Cache\ExternalEncoder)
2014-09-09 12:10:24:391 rpc.encoder-process      [I] Starting Write Thread.
2014-09-09 12:10:24:391 rpc.encoder-process      [I] Starting Read Thread.

transcoding.log

>>>>> 2014-09-09 <<<<<

12:07:31 INFO  transcoding.manager LiveTranscoding.h:788  - - - Initializing live transcoding for 'E:\Videos\Movie (2014)\Movie.mkv'
12:07:31 ERROR transcoding.manager LiveTranscoding.h:867  - - - Error creating transcoding session: Air Video Server HD is missing codec: AC3. Please see Air Video Server HD properties, this can most likely be resolved.
12:07:38 INFO  transcoding.manager LiveTranscoding.h:788  - - - Initializing live transcoding for 'E:\Videos\Movie (2014)\Movie.mkv'
12:07:38 ERROR transcoding.manager LiveTranscoding.h:867  - - - Error creating transcoding session: Air Video Server HD is missing codec: AC3. Please see Air Video Server HD properties, this can most likely be resolved.

>>>>> 2014-09-09 <<<<<

12:10:47 INFO  transcoding.manager LiveTranscoding.h:788  - - - Initializing live transcoding for 'E:\Videos\Movie (2014)\Movie.mkv'
12:10:47 ERROR transcoding.manager LiveTranscoding.h:867  - - - Error creating transcoding session: Air Video Server HD is missing codec: AC3. Please see Air Video Server HD properties, this can most likely be resolved.
12:10:52 INFO  transcoding.manager LiveTranscoding.h:788  - - - Initializing live transcoding for 'E:\Videos\Movie (2014)\Movie.mkv'
12:10:52 ERROR transcoding.manager LiveTranscoding.h:867  - - - Error creating transcoding session: Air Video Server HD is missing codec: AC3. Please see Air Video Server HD properties, this can most likely be resolved.



#5 admin

admin

    Administrator

  • Administrators
  • 2582 posts

Posted 09 September 2014 - 07:31 PM

Does your VLC version match Air Video Server HD version? I.e. 32bit server needs 32bit VLC, 64bit server needs 64bit VLC.



#6 Hwinter

Hwinter

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 09 September 2014 - 10:08 PM

I didn't know that was a 32 and a 64 bit version of VLC. I simple downloaded the installer package from http://www.videolan....ad-windows.html. The "about" within VLC doesn't tell me if it is 64 or 32 bit.

Having said that, I'm running Windows 8.1 (64bit).

#7 admin

admin

    Administrator

  • Administrators
  • 2582 posts

Posted 09 September 2014 - 10:23 PM

Hi,

 

the "default" link points to 32bit VLC. Here is the latest 64bit VLC installer

 

http://download.vide...2.1.5-win64.exe



#8 Hwinter

Hwinter

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 10 September 2014 - 01:19 AM

That is better, but now I I have some movies (mostly trailers) that I get a message "this file contains no playable stream", but it actually plays when I click on it.

#9 admin

admin

    Administrator

  • Administrators
  • 2582 posts

Posted 12 September 2014 - 10:47 AM

It could be that you'll need to reset thumbnail cache.

 

http://forums.inmeth...humbnail-cache/



#10 maskintvatt

maskintvatt

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 14 September 2014 - 01:24 PM

Norvegian/Nordic special charactes in subtitles are not shown correctly. They do in 1.0.15.



#11 admin

admin

    Administrator

  • Administrators
  • 2582 posts

Posted 14 September 2014 - 02:27 PM

Latin 1/2 detection is broken in this beta. It's a regression that will be fixed in next verison.



#12 whenamanlies

whenamanlies

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 18 September 2014 - 05:19 AM

Have some problems using beta2 with 1.x client from the App Store:

- in the list correct video length is displayed and it is correctly displayed when playback begins however after scrolling to futher point length would increase (26min video becomes 70min one)

- subtitles for some videos would stop displaying after minute or so (also repros with 2.0 on same iPhone 5c)

 

Have you seen anything like that?



#13 admin

admin

    Administrator

  • Administrators
  • 2582 posts

Posted 18 September 2014 - 10:42 AM

Hi,

 

did this start happening after upgrade to iOS 8? The length duplication is a bug in iOS 8 and we have workaround for it in next update (already submitted to Apple for review). However I'm not aware of subtitle stopping to show, can you send me sample subtitle file to support (at) inmethod.com ? (if it is external subtitles)



#14 pcalamode

pcalamode

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 19 September 2014 - 02:36 AM

ADMIN, please ad the Cover Art Integration finally. PLEASE. Sometimes the thumbs that are generated show a thumbnail with naked titts and this is not a good example. Please AD Cover Art.



#15 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 126 posts

Posted 19 September 2014 - 01:51 PM

I have updated my iPad to iOS 8 and my Apple TV 3 to 6.2. Beta2 is playing videos well. I don't use subtitles so I can't comment on that.



#16 admin

admin

    Administrator

  • Administrators
  • 2582 posts

Posted 19 September 2014 - 10:43 PM

Hi guys, 2.0 is available. Should fix subtitles on Apple TV with latest firmware. It probably won't help with subtitles disappearing on client, so far I don't know what causes that. I wasn't able to reproduce it with current client, but I must admit that we haven't tested 1.0.3 with iOS 8 extensively. The original plan was to ship 2.0 by the time iOS 8 was out, but it got a bit delayed (currently waiting for review)



#17 whenamanlies

whenamanlies

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 22 September 2014 - 05:06 PM

No longer have subtitle problem. Perhaps it was fixed either with client or server update.

Looking better every day!



#18 admin

admin

    Administrator

  • Administrators
  • 2582 posts

Posted 22 September 2014 - 05:07 PM

whenamanlies, 2.0.1 should fix the subtitle problem.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users