Jump to content


Photo

64Bit app and Server


  • Please log in to reply
42 replies to this topic

#1 el_Capitan

el_Capitan

    Advanced Member

  • Members
  • PipPipPip
  • 52 posts

Posted 05 May 2014 - 08:27 PM

Are there any plans to switch these to a 64bit base? Im reading that Windows ends 32 bit support with win8 and that Win9 will only support 64bit applications. Apple has already made the move to 64bit but retains the 32bit legacy.

 

I would guess that 64 bit would tax my CPU less and utilize the hardware on the iphone better, also allowing more funtionality, correct?



#2 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 05 May 2014 - 08:30 PM

Hi,

 

while Windows 9 might be 64bit only, it will still support 32bit applications. However should be releasing a 64bit Windows server soon. 



#3 jeromec

jeromec

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 07 May 2014 - 05:53 PM

On my OS X Mavericks Mac, Activity Monitor reports Air Video Server HD as a 64bit app.

But since Instruments reports the Air Video HD running on my iPad Air as 32bit, it seems that 64bit still has to come to Air Video Server HD on Windows, as well as the Air Video HD app.



#4 el_Capitan

el_Capitan

    Advanced Member

  • Members
  • PipPipPip
  • 52 posts

Posted 08 May 2014 - 07:27 AM

Thank admin I appreciate your info



#5 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 08 May 2014 - 10:17 AM

The 64bit beta server should be available for testing soon. 



#6 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 128 posts

Posted 09 May 2014 - 01:13 PM

I would like to be able to try it out.

 

RMcV



#7 el_Capitan

el_Capitan

    Advanced Member

  • Members
  • PipPipPip
  • 52 posts

Posted 23 May 2014 - 12:22 AM

Any news on the 64bit version?

#8 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 24 May 2014 - 01:36 PM

I just pushed new test build, you can get it here

 

https://s3.amazonaws...6-beta3-x64.exe



#9 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 128 posts

Posted 25 May 2014 - 11:31 AM

I installed it this morning. I'll give it a try today.

 

I tried it out for a couple of hours with no problems. Good work!

 

I tried it for a few hours last night with no problems. Connecting to the server and starting a video seems a little faster.

 

Now the big question ... :-) Can I get rid of 32 bit Videolan?



#10 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 128 posts

Posted 27 May 2014 - 01:00 PM

Now the big question ... :-) Can I get rid of 32 bit Videolan?

 

It looks like I answered this question myself. I uninstalled 32 bit Videolan and everything still works fine.

 

RMcV



#11 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 27 May 2014 - 02:06 PM

Yes. 64bit VLC will be used instead (if available).



#12 el_Capitan

el_Capitan

    Advanced Member

  • Members
  • PipPipPip
  • 52 posts

Posted 28 May 2014 - 07:38 AM

I got my hands on WS2012E R2 so its was another reinstall tonight. It went faster then I thought. I was happy to find that you posted a 64bit version of the server. I installed and it seems to be a little quicker. Ill be giving it the full workout the next few days while I'm at work and at the gym. THANK YOU!!! now just need a 64bit version of the app. I can't wait to see what the new iPhone and IOS 8 brings. You guys are fantastic about keeping up with future growth of the platform. Thank you.



#13 el_Capitan

el_Capitan

    Advanced Member

  • Members
  • PipPipPip
  • 52 posts

Posted 30 May 2014 - 03:30 AM

So gave I gave it a try,  I have to agree that the interface seems snappier. I tried Air video without any additional codecs (No CCCP or VLC). Im excited to get a 64bit IOS app now. I wasn't able to watch any movies being that i was at work but I can use my Bluetooth headsets to listen to shows. everything that could play without special codecs paid fine. I did have 1 issue playing a 1080p video. This was the same video that gave me issues on the 32bit version past 1.0.11. It paused 2 times in the beginning then played flawlessly after that a definite improvement over the 32bit version. I will be continuing to test this over the weekend.

 

Let me know if you need help testing the IOS app id be happy to help.

 

Im installing 64bit VLC now.



#14 el_Capitan

el_Capitan

    Advanced Member

  • Members
  • PipPipPip
  • 52 posts

Posted 31 May 2014 - 04:48 AM

RMcV

 

Do you have an Apple TV to test out airplay?

 

I would like to see how the server handles that task.



#15 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 128 posts

Posted 31 May 2014 - 01:04 PM

@ el_Capitan

 

Yes I do; a 3rd generation Apple TV. It works great with AirVideo HD, no issues.



#16 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 31 May 2014 - 07:15 PM

New version that should improve the ExternalEncoder error on shutdown

 

https://s3.amazonaws...6-beta4-x64.exe



#17 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 128 posts

Posted 01 June 2014 - 11:52 AM

I have installed the beta 4 and will try it out today. I don't have the "the ExternalEncoder error on shutdown" error so I guess I may not see any difference.



#18 tdoane78

tdoane78

    Advanced Member

  • Members
  • PipPipPip
  • 140 posts

Posted 02 June 2014 - 09:42 AM

Downloaded and no issue so far with the new 64-bit version. Never had the ExternEncoder error either.

 

-Tim



#19 RMcV

RMcV

    Advanced Member

  • Members
  • PipPipPip
  • 128 posts

Posted 02 June 2014 - 12:12 PM

I've had no issues with 64 bit beta 4 in terms of playing videos.

 

I had a heck of a time making AVHD available over the internet. On the preferences main screen it says "UPnP port mapping not possible. The server is not reachable directly from the internet.", but when I click on the "Test Connection" button the popup says "Server is accessible from the Internet." Somebody's not right! :lol: I have not been able to go somewhere else to see if I can connect from outside my network.



#20 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 02 June 2014 - 12:21 PM

Did you configure port mappings on router manually? In that case the UPnP error is not really relevant.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users