Jump to content


Photo

No Subtitles with Apple TV 6.1 update


  • Please log in to reply
11 replies to this topic

#1 abat119

abat119

    Member

  • Members
  • PipPip
  • 25 posts

Posted 10 March 2014 - 08:19 PM

So I just updated my Apple TV to 6.1 and for some reason the subtitles (.srt) stopped working (via AirPlay).

 

They worked litterally 5 minutes before! (Before the update...).

 

Can't figure out how to get them back...

 

Hoping this is a software issue that can be fixed easliy... or even better - my stupidity so that I can get a quick and easy answer : - )

 

Thanks!

 

Love the product!


  • WalterPt likes this

#2 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 10 March 2014 - 09:19 PM

I just installed the update and can confirm that subtitles are broken. We have various workaround for different Apple TV firmware versions, looks like every new update finds a way to break the subtitles in another way. Expect a server update very soon.

Edit: To be fair, upon closer look, one of the workarounds that we have for Apple TV did not get applied for the new firmware. So it is just version check gone bad. 


  • WalterPt likes this

#3 abat119

abat119

    Member

  • Members
  • PipPip
  • 25 posts

Posted 10 March 2014 - 09:53 PM

Great!

 

Thanks for the quick reply!



#4 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 10 March 2014 - 11:31 PM

The update should be available now.



#5 abat119

abat119

    Member

  • Members
  • PipPip
  • 25 posts

Posted 11 March 2014 - 07:12 PM

Works great!

 

Thanks again.



#6 Danny

Danny

    Advanced Member

  • Members
  • PipPipPip
  • 99 posts

Posted 12 March 2014 - 03:25 AM

Just for info admin - I used the Check for Updates within AVHD. The update came in and this is the first time but I did get the request of Protected by Password for the update on clicking to install. I just left it blank and clicked OK. It  installed fine and relaunched. This occurred on two different computers using check for updates.

 

I posted this because of this thread where I informed I didn't get this PW request. http://forums.inmeth...word-to-update/

 

Thanks for the update.



#7 iamse7en

iamse7en

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 21 May 2014 - 03:26 AM

My server, client, and AppleTV are all up-to-date, but I'm having this problem.

 

Subtitles work on the iPad, but when I try to AirPlay, it doesn't work. I was forced to use StreamToMe which works flawlessly regardless of when an AppleTV update comes out.



#8 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 21 May 2014 - 08:00 AM

That's because it always render the subtitles to the video. You can get the same in Air Video HD by enabling "Force Hard Subtitles" in Settings. However the subtitles work even without this. Can you please send the logs (Create Archive from Logs) to support (at) inmethod.com? Also, do you have custom language set in Apple TV settings? ( Settings > Audio & Video > Subtitle Language )



#9 Hwinter

Hwinter

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 06 September 2014 - 01:41 PM

I'm having the same problem and I also have the latest versions of AppleTV 3, Server and iPad/iPhone app. Here are the logs:

 

-transcoding.log

09:34:11 INFO  transcoding.tsmuxer PipelineSegments.h:875 - - - Transcoding Rate: 109% realtime, Average Bitrate: 3227kbps (not accurate - transcoding throttled)
09:34:13 INFO  transcoding.manager LiveTranscoding.h:806  - - - Closing transcoding session session87-6b66eab2-35ca-11e4-95a6-3085a9a93ed6
09:34:13 INFO  transcoding.tsmuxer PipelineSegments.h:875 - - - Transcoding Rate: 862% realtime, Average Bitrate: 3735kbps (not accurate - transcoding throttled)
09:34:13 INFO  transcoding.transcoder GstLiveTranscoder.h:132 - Destroying Transcoder
09:34:13 INFO  transcoding.transcoder BaseGstTranscoder.h:197 - Removing elements
09:34:26 INFO  transcoding.tsmuxer PipelineSegments.h:875 - - - Transcoding Rate: 109% realtime, Average Bitrate: 3228kbps (not accurate - transcoding throttled)
09:34:36 INFO  transcoding.tsmuxer PipelineSegments.h:875 - - - Transcoding Rate: 109% realtime, Average Bitrate: 3229kbps (not accurate - transcoding throttled)
09:34:51 INFO  transcoding.tsmuxer PipelineSegments.h:875 - - - Transcoding Rate: 109% realtime, Average Bitrate: 3241kbps (not accurate - transcoding throttled)
09:34:54 INFO  transcoding.manager LiveTranscoding.h:711  - - - Initializing live transcoding for 'E:\Videos\Movies\Maleficent (2014)\Maleficent.mkv'
09:34:54 INFO  transcoding.manager LiveTranscoding.cpp:68 - - - Creating topology for video: passthrough, audio: none, audio alt: 160
09:34:54 DEBUG transcoding.manager LiveTranscoding.cpp:96 - - - Topology - creating video stream video_0
09:34:54 DEBUG transcoding.manager LiveTranscoding.cpp:116  - - Topology -   creating subtitle stream from file E:\Videos\Movies\Maleficent (2014)\Maleficent.en.srt
09:34:54 DEBUG transcoding.manager LiveTranscoding.cpp:123  - - Topology -   creating passthrough video branch
09:34:54 DEBUG transcoding.manager LiveTranscoding.cpp:149  - - Topology - creating subtitle passthrough branch
09:34:54 DEBUG transcoding.manager LiveTranscoding.cpp:169  - - Topology - creating audio stream audio_0
09:34:54 DEBUG transcoding.manager LiveTranscoding.cpp:184  - - Topology -   creating audio transcoding branch (160)
09:34:54 DEBUG transcoding.manager LiveTranscoding.h:768  - - - Created transcoding session: /live-transcoding/playlist/session88-9634c098-35ca-11e4-825e-3085a9a93ed6/master.m3u8
09:34:55 INFO  transcoding.transcoder GstLiveTranscoder.h:61  - Creating transcoder for 'E:\Videos\Movies\Maleficent (2014)\Maleficent.mkv' with initial offset 3495.000000s
09:34:55 FIXME gst.default gstutils.c:3626  - - - - - - - - - - Creating random stream-id, consider implementing a deterministic way of creating a stream-id
09:34:55 WARN  gst.typefind gsttypefindelement.c:770  - - - - - failed to query peer uri
09:34:55 FIXME gst.default gstutils.c:3626  - - - - - - - - - - Creating random stream-id, consider implementing a deterministic way of creating a stream-id
09:34:55 FIXME gst.default gstutils.c:3626  - - - - - - - - - - Creating random stream-id, consider implementing a deterministic way of creating a stream-id
09:34:55 WARN  gst.matroskareadcommon matroska-read-common.c:513  Unknown ChaptersEdition subelement 0x45db - ignoring
09:34:55 WARN  gst.matroskareadcommon matroska-read-common.c:513  Unknown ChaptersTitles subelement 0x437c - ignoring
09:34:55 WARN  gst.matroskareadcommon matroska-read-common.c:513  Dý® (repeated 215804080 times)
09:34:55 INFO  transcoding.transcoder BaseGstTranscoder.h:77  - Added pad video_0 - No Decoder (bufferskip862), video/x-h264,level=4,profile=high,stream-format=avc,alignment=au,w=1916,h=796,PAR=1/1,fps=8000000/333667,parsed=true,codec_data=buffer
09:34:55 INFO  transcoding.transcoder BaseGstTranscoder.h:77  - Added pad audio_0 - VLCAudioDecoder (vlcaudiodecoder_ac3-57), audio/x-raw,format=F32LE,layout=interleaved,rate=48000,channels=6,channel-mask=0x000000000000003f
09:34:55 INFO  transcoding.transcoder BaseGstTranscoder.h:77  - Added pad audio_0 - No Decoder (bufferskip866), audio/x-ac3,framed=true,rate=48000,channels=6,alignment=frame
09:34:55 INFO  transcoding.transcoder BaseGstTranscoder.h:82  - Added subtitle pad application/x-attributed-text
09:34:56 INFO  transcoding.tsmuxer PipelineSegments.h:875 - - - Transcoding Rate: 9178% realtime, Average Bitrate: 4094kbps (accurate)
09:34:57 INFO  transcoding.tsmuxer PipelineSegments.h:875 - - - Transcoding Rate: 6383% realtime, Average Bitrate: 3789kbps (accurate)
09:34:58 INFO  transcoding.tsmuxer PipelineSegments.h:875 - - - Transcoding Rate: 5402% realtime, Average Bitrate: 3985kbps (accurate)
09:34:59 INFO  transcoding.tsmuxer PipelineSegments.h:875 - - - Transcoding Rate: 4918% realtime, Average Bitrate: 3812kbps (accurate)
09:35:05 INFO  transcoding.tsmuxer PipelineSegments.h:875 - - - Transcoding Rate: 109% realtime, Average Bitrate: 3234kbps (not accurate - transcoding throttled)
09:35:20 INFO  transcoding.tsmuxer PipelineSegments.h:875 - - - Transcoding Rate: 109% realtime, Average Bitrate: 3218kbps (not accurate - transcoding throttled)
09:35:31 INFO  transcoding.tsmuxer PipelineSegments.h:875 - - - Transcoding Rate: 109% realtime, Average Bitrate: 3209kbps (not accurate - transcoding throttled)
09:35:33 INFO  transcoding.manager LiveTranscoding.h:806  - - - Closing transcoding session session88-9634c098-35ca-11e4-825e-3085a9a93ed6
09:35:33 INFO  transcoding.tsmuxer PipelineSegments.h:875 - - - Transcoding Rate: 597% realtime, Average Bitrate: 3714kbps (not accurate - transcoding throttled)
09:35:33 INFO  transcoding.transcoder GstLiveTranscoder.h:132 - Destroying Transcoder
09:35:33 INFO  transcoding.transcoder BaseGstTranscoder.h:197 - Removing elements

Network.log:

09:34:51 INFO  managerState ManagerState.cpp:83 - - - - - - - - Session 118 Begin - User: master, Device: Hans iPhone 5s, Address: 192.168.10.120
09:38:39 INFO  managerState ManagerState.cpp:204  - - - - - - - Session 118 End

There was nothing on the other log files.



#10 admin

admin

    Administrator

  • Administrators
  • 2585 posts

Posted 06 September 2014 - 01:53 PM

The log is not really relevant. IF subtitles don't show up on Apple TV the most likely reason is custom language in Apple TV settings. (see my previous post)



#11 hunpff

hunpff

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 07 September 2014 - 03:45 AM

Hold the middle button in your Apple Remote and choose Auto or one of the other subtitles listed in there and the subtitles should appear

 

;-)



#12 Hwinter

Hwinter

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 09 September 2014 - 03:32 PM

Yep, that is what I did and it worked! (Auto)

Thanks!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users